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CHAPTER 1 - GETTING STARTED

1.1 Getting Started in Power BI Desktop

This chapter describes the basic workflow you’ll use to build a report in Power BI Desktop:

Stage Details
Loading and 
transforming data

Loading one or more tables from various data sources, cleansing the data and 
linking the tables together if necessary.

Creating a report Using the data that you’ve loaded to create a report, including visuals like charts.

Publishing this Publishing the results to your report server (usually Microsoft’s Power BI Service) 
so that other people can view your reports.

You’ll find much more detail on the ideas mentioned in this chapter in later parts of this courseware.

Example for this Chapter

To demonstrate the basic process of building a report, we’ll import a table of data from a webpage 
and create and publish a report based upon this:

We’ll then present this data using visuals such as this chart:

Finally we will publish this report to the Power BI Service, 
so that anyone in your organisation can see it:

At the time of writing these are the snow 
conditions at selected resorts courtesy of 
https://www.igluski.com/snow-reports . 
We’ll transform the data to tidy it up (for 
example, we can remove columns we 
don’t need).

We can use the imported, cleaned data to create a variety of 
visuals, such as this chart.

The final report published to Power BI Service, and viewed 
through your browser.

https://www.igluski.com/snow-reports
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1.2 Working with Files

Creating New Files

You can create a new report in Power BI Desktop in the following ways:

Opening and Saving Files

You can open and save files using options in the File menu:

a) From the Power BI Desktop menu choose the File menu.

d) Files that you save in 
Power BI Desktop will have 
a pbix extension.

a) If you already have Power BI 
Desktop open, select the File menu.

b) Click on this icon to create a new 
report.

b) Choose one of these menu items to open or save a report (the 
dialog box which appears is similar whichever you choose).

c) Click on this button to find the 
folder which contains (or will 
contain) your report.

e) Click on this button to open 
the report you’ve chosen or 
to save this report

Every time you open a Power BI Desktop report a new instance of the application 
will launch, leaving the current report you’re working on unaffected.  To close a report 
you must close down the Power BI Desktop application containing it (there is no 
option to close a report but still leave Power BI Desktop running).

Wise 
Owl’s 
Hint
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1.3 Views in Power BI Desktop

The most important components of the Power BI Desktop screen are as follows:

Switching Panes

You can use the icons on the right-hand side of your Power BI screen to choose what to show:

You can click the arrows to 
hide each of these panes.

This is the Power 
BI Desktop menu 
and ribbon. 

You can use the Pane Switcher to change 
what to look at.  The two main views are 
Data and Format, as explained below.

These tools allow you to switch between 
designing reports for viewing on desktop 
computers or mobile phones.

These tools allow you to switch between 
the 3 main views in Power BI Desktop: 
Report view, Table view and Model view.

You can use the slider to zoom in and out, although you 
may find it easier to hold down the  Ctrl  key and use your 
mouse wheel instead.

Click on this icon to see the data tables in your model …

… or this icon to see the format properties of the thing 
you currently have selected (in this case a chart visual).

You can also use these tools on the View tab of the 
Power BI Desktop ribbon to choose what you want to 
view.
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Report, Table and Model View

You can switch between the three views of a report using the tools on the left of the screen:

View Icon What it shows Example view

Report

The report that 
you’re creating, 
consisting of visuals 
and shapes.

Table

The tables of data 
that you’ve loaded 
into your model (you 
can see one table at 
a time in this view).

Model

The links between 
the tables in your 
model, called 
relationships in 
Power BI Desktop.

The 4th icon – if present – allows you to create queries in DAX to interrogate the data 
upon which your report is based, but this is definitely not something to consider in 
this courseware chapter!

Wise 
Owl’s 
Hint
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1.4 Getting Data

The first stage in building a report is to find some data!

 

You can optionally rename a table after importing it into your report:

a) From the ribbon, choose Home | Get Data then choose a type of 
data source.  Here we’re choosing a Web source.

d) Click on this button to load the 
data into your model.

a) Click on this icon to show the Data pane.

b) Choose Rename from the menu which 
appears.

b) Each type of data source requires different information to allow 
your report to connect to it.  For a web source you need to enter 
the URL of the page and then click OK.  You may also be asked to 
enter credentials if the website requires some.

c) Tick which table you want to 
import from this page (the best 
way to see what each looks like 
is to click on it).

c) Enter a new name for your table and 
press  Enter  .
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1.5 Transforming Data

You’ll often need to make changes to the data you have imported so that it can be presented easily 
in visuals.  This process is known as transforming data.

Editing Queries /  Transforming Data

Each table that you import into a report generates a query which tells Power BI Desktop which data 
to get (and how to get it).  You can edit these queries in (at least) 3 different ways:

You can right-click on a table in the Fields pane and choose Edit 
query…

…or you can choose this option from the Home tab of the ribbon 
(although it says it’s doing something different, transforming data and 
editing a query are actually the same thing!).

As with everything else in this chapter, we will go into this topic in much more detail 
later in this courseware.

Wise 
Owl’s 
Hint

Alternatively, you could click on this button at the point at which you’re 
first loading data to go directly into the Power BI Query Editor.

We will change the column 
headings, turn some 

column into numbers and 
remove the final column.
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The Power BI Query Editor

Choosing to edit a query as described above opens the Power Query Editor tool within Power BI 
Desktop.

Promoting Row Headers

For our example the first thing you need to do is to make the first row your table headers:

Although you’re still working in the 
same Power BI Desktop file, the 
Power Query Editor has a different 
ribbon with options related to 
modifying data.

When you have finished cleaning your 
data click Close & Apply to close the 
Power Query Editor.

This program to edit Power BI queries has gone by many names in the past!  This 
courseware will call it Query Editor, although this name seems to have been 
abandoned by Microsoft.  Little known fact: everything that you can do using Query 
Editor in Power BI Desktop you can also do when getting data in Excel.

Wise 
Owl’s 
Hint

a) To tell Power BI Desktop to use the first 
row of the table as column headers, click 
on this tool on the Home tab of the 
Query Editor ribbon:

b) Query Editor will add two steps: one to promote your row headers (as 
requested), and then another to change the data types of the columns 
following this step.  Query Editor will often insert silent additional steps like 
this to second-guess your intentions, and (to be fair) nearly always gets 
these right.
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Replacing Values

To allow us to average snowfalls for our data we need to remove the cm suffices then convert the 
resulting data to integer numbers:

Changing Data Types

You can now change the data 
types of the 3 columns you have 
selected:

Removing Columns

Finally, we’re not interested in the last snowfall depth, so we’ll remove this column.

a) Select the first column whose cm suffices you 
want to remove, then hold down the  Shift  key 
and select the last one (this is the easiest way to 
select multiple columns in Query Editor).

b) Right-click on the selected columns and choose 
to replace values.

c) Choose to replace the text cm with nothing, then select  OK  .

Right-click on the 3 columns and 
choose to change their data types 
to Whole Number (note that this 
would have generated errors if we 
had done this earlier).

Right-click on the Last Snowfall column and remove it 
from your query.
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1.6 Creating Visuals

Visuals are the tables, charts or other gizmos which display the data in your report.  There are many 
types of visual ( you’ll learn a lot more about them in later chapters of this courseware).

Inserting a Visual

Probably the easiest way to add a visual to a report is as follows:

Assigning Grouping Fields to a Visual

Once you have inserted a visual you can begin assigning fields to it:

  

b) Click on the side bar to the right of the visuals pane (this appears on both 
the Home tab and the Insert tab of the ribbon).

b) Choose which visual you want to create.  If you get this wrong, 
you can always change it after creating your visual by clicking 
here:

a) Make sure that you’re in Report view, otherwise you won’t be able to add 
visuals!

The easiest way to 
assign fields to a visual 
is to click on this tool.

You can then click on 
each part of a chart 
(here we’re saying what 
will appear on the 
horizontal axis of this 
column chart) then tick 
the field you want to 
include.
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Assigning Numerical Fields

You can assign numerical fields in the same way, then change how you want to aggregate them:

c) Once you’ve assigned a numerical field to a 
chart you can click on it to say how you want to 
aggregate it (here we’ve changed from 
summing the upper slopes’ snow depth for each 
country – which would be fairly meaningless – 
to averaging it). 

a) Click on the Y axis box the field well and choose to 
show the Upper Slopes snow depth to get this:

b) Click on the field you’ve added and change it:
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1.7 Three Ways to Format Visuals

Much of your time in Power BI Desktop will probably be spent applying formatting like this:

In Situ Selection

There are a few parts of a chart that you can edit on the chart itself:

Changing what’s on your Chart

You can choose to add or remove some parts of your 
chart using the following icon:

The chart as it initially appears – the 
title is hard to read and doesn’t stand 
out, and it could do with a bit of oomph.

A chart which has been formatted within 
an inch of its life (including the addition 
of data labels showing the average 
upper bound snow level by country).

The parts of the chart you can edit directly are shown in red boxes.

When you double-click on any of these with the chart selected you will 
be able to change the text displayed.

Click on this icon to add or remove certain chart 
components (here we can add or remove the title, data 
labels or a slider).

The More options button is less useful than you might think: it just takes you to the 
Format pane on the right-hand side of Power BI Desktop.

Wise 
Owl’s 
Hint
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The Format Pane

You’ll spend much of your time in Power BI Desktop using the Format pane:
 

a) Select the visual you want to 
format (otherwise you’ll see the 
formatting properties of the page to 
which it belongs instead).

b) Optionally, reduce the number of 
properties displayed by typing in 
part of the name of the one you 
want to change (here we’ve typed 
Title in the search box).

c) Expand a card to show its range of 
formatting options, and make 
changes.

d) Some of the changes made to 
change the title to this:

As a short-cut, double-click on a visual  to select any part of it that you want to format; 
the relevant card will automatically then be selected in the Format pane.

Wise 
Owl’s 
Hint
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1.8 Publishing your Report

When you’ve finished your report you will probably want to share it!

a) Check that you’re signed 
in to a Power BI account.

b) Click on this Publish 
button on the Home tab of 
the Power BI ribbon.

c) If you have unsaved changes you will be asked at this point to 
save them (you can’t publish a report which contains unsaved 
changes).

d) Choose to publish 
to the default My 
workspace (see 
hint below for 
more on this).

e) Click on this link to see your report in Power BI 
Service on the Internet (you may be asked to log in 
to your account again at this point).

f) Your report as it will appear to the world 
(provided of course that they have the right 
security level and licence …).

A (much) later chapter in this courseware will cover publishing in more detail, 
including an explanation of workspaces (and why you might want to create them), 
how to create dashboards and much more besides.

Wise 
Owl’s 
Hint
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CHAPTER 2 - IMPORTING DATA

2.1 Our Example

Our example is based on a relational database which keeps track of sales of soft toys.  The diagram 
below shows which type of data source we’ll use to import each table: 

PBI Dataset

Website

Pasted (Word) 

SQL Server

Typed in

CSV file

Excel

ExcelExcel

Website

CSV file
SQL Server

Pasted

Excel Excel

Excel

Typed in

Excel

Once you’ve loaded your data into Power BI from disparate data sources all tables 
will be treated equally (so for example you can join a table imported from Excel with 
one imported from a website without any problem).

Wise 
Owl’s 
Hint
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2.2 Importing from Different Sources

This section shows how to import data into a report from a variety of common data source types.  
Regardless of which data source type you’re using, you can begin the import process as follows:

Re-Using a Data Source

You can quickly re-use a recent data source as shown below:

What happens next depends on which data source type you’ve chosen, but it 
inevitably involves launching some type of wizard which will help you import your 
data.

Wise 
Owl’s 
Hint

a) From the ribbon choose Home | Get Data.  You can also click the top 
half of the Get Data tool to open the dialog box shown below, or click 
on this link in a new report: 

b) Pick a data source type from the Common data sources list, or click 
More… to see more choices.

a) From the ribbon choose Home | 
Recent Sources.

b) Pick from the list of databases, 
workbooks, websites, etc from which 
you’ve already imported data.
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2.3 Importing from Excel

To start importing from an Excel workbook, use this short-cut:

The dialog box which appears lists the contents of the workbook you have selected.  You can choose 
which parts of the workbook you want to import as shown below: 
  

Note that Power BI Desktop will where 
possible build relationships between the 
worksheets you’ve imported:

The dialog box will list 
worksheets in your workbook, 
but also named ranges in the file 
such as RegionList here.  These 
names ranges have a different 
icon next to them and appear at 
the bottom of the list of options.

Tick the box next to the name of 
any item you want to import.  
Here we’ve chosen to import the 
Centre, Region, Sales and 
Town worksheets.

Power BI gives you a special Excel tool 
because it’s such a popular choice.

Double-click on a workbook containing 
one or more worksheets or named 
ranges that you want to import.

When you’ve chosen which 
worksheets or named ranges you 
want to import choose either to 
load them into your model or to 
go to Query Editor for further 
processing.

Power BI Desktop creates these relationships for this 
example (we’ve tidied the diagram up a bit).  You’ll 
learn how and why Power BI Desktop creates 
relationships between pairs of loaded tables in another 
chapter in this courseware.
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2.4 Importing CSV or Text Files

You can import from CSV files as well as a variety of other text file types.
 

To begin importing from a text file like this:
 
 

You can then choose exactly how the text file is configured using the dialog box which appears:

Choose to get data from a Text/CSV file …

CSV stands for Comma Separated Values.  The value in one column is 
separated from the next by a comma.  Our example file also includes a 
row of column headers.

… then browse for and double-click the file you want to import.

The preview of your data is a 
good way to check if you’ve 
selected the correct options.

If Power BI Desktop hasn’t 
picked the correct delimiter, 
you can choose a new one.

Power BI Desktop attempts to work out the 
data type of each column using a sample of 
rows.  You can set the sample size here.

When you’ve finished configuring the 
text file, click the Load button to import it 
into your Power BI report.

Optionally you can click on this button to train Power BI on which 
columns you want to import, although it’s usually easier to import 
everything then remove from the query the columns you don’t want.
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2.5 Importing from SQL Server 

You can import data from a SQL Server database as shown in the diagram below:

 w

b) Enter a server name and, optionally, the name of a database.

c) Choose to Import the data and then click OK (see the hint 
below for more on what DirectQuery means).

d) If required enter your credentials to connect to the 
server you have chosen.  Click Connect when 
you’ve done so - you may then have to confirm 
you’re happy to use an unencrypted connection:

e) In the next dialog box you 
can pick from a list of 
tables to import.  Here 
we’ve chosen to import 
the Environment table.

If you’re wondering, DirectQuery means you don’t import the data into your model: 
you just link to it.  On the plus side this means that the data in your visuals is always 
up to date, but on the downside reports may run more slowly, and there are 
numerous limitations (for example, you can only use a few types of data source and 
you can’t use something called calculated columns).

Wise 
Owl’s 
Hint

a) Like Excel, SQL 
Server has a 
dedicated import tool!
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Using Queries and Stored Procedures

Rather than choosing to import from a list of tables, you can write a query to return your data.  This 
is more complicated but provides much more control over which data you get.

  

Passing Arguments to Stored Procedures

Note that you can now pass arguments to a stored procedure 
using these advanced options:

a) It’s much easier to test your 
query in SQL Server 
Management Studio than it 
is to type it into Power BI!  
When your query or stored 
procedure is working, copy 
the query text or the name 
of the stored procedure to 
the clipboard.

b) While loading SQL Server data, choose to show advanced options.

c) Choose either to execute a 
stored procedure (left) or run a 
query (right).  Either option will 
then let you load your data:

Be careful: Power BI Desktop 
seems to have a preference for 
choosing Direct Query when 
you load data from SQL Server 
like this; be sure to set this back 
to Import.

CREATE PROC spListTowns(
@region varchar(100)

)
AS

-- list the towns in any given 
region
SELECT

t.TownName AS Town,
t.TownId 

FROM 
Town AS t
JOIN Region AS r ON t.RegionId 

= r.RegionId
WHERE

r.RegionName = @region

Here we have a stored procedure listing out all the towns for any 
given region.  We could load this as follows:
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2.6 Importing from a Website

Power BI Desktop makes it easy to grab data from a website, as shown below:

a) Find a website which contains 
a table of data that you want to 
import (this one is at 
wiseowl.co.uk/sundry/pbd1/ ).

b) Choose to get data from a 
Web source in the Other 
category.

c) Enter the URL of the page 
containing the table you 
want to import and click 
OK.

f) Choose one of these buttons to 
load the data directly or to further 
process it before loading:

d) If this is the first time 
you’ve connected to this 
page you’ll be asked if you 
want to use any 
credentials.  Here we’re 
opting to connect to the site 
anonymously.

e) Tick the box next to any table you 
want to import.  

http://www.wiseowl.co.uk/sundry/pbd1/
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2.7 Entering Data Manually

As well as importing existing data, Power BI Desktop allows you to enter data into a model manually.

Pasting Data

Although you can’t import directly from Word, you can copy and paste:

 

If you copy and paste data, you obviously won’t be able to refresh the resulting table 
to bring in updates.

Wise 
Owl’s 
Hint

a) In Word, select the table you want to import and 
copy it. b) Click on this button to enter data into a new table.

c) Right-click on the empty grid and choose to paste in 
your data.

e) Give your table 
a better name.

d) Power BI Desktop will decide whether the first row 
of your table should become the header columns.

f) Choose to Load 
it into your data 
model.
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Typing in Data

The final option for loading data into a model in Power BI Desktop is to type it in!

a) From the ribbon select this 
icon to enter data.

b) You can overtype any 
column name to rename it.

c) Type in the data that you 
want to store in the table.

d) Right-click to insert any 
additional columns that you 
need.

e) Type in any data for new 
columns that you’ve added.

f) Give the table a name and 
click Load to add it to the 
report.



 
 

www.wiseowl.co.uk   |   (0161) 883 3606   |   sales@wiseowl.co.uk 

 

WHAT WE DO 
 
 
 

 

   

 

 
 

ONLINE 
TRAINING 

 

 
 

MANCHESTER  
OR LONDON 

 

 
 

AT YOUR 
OFFICE 

 

 
 

BESPOKE 
CONSULTANCY 

O
F
F
I
C

E
 

3
6

5
 

Microsoft 

Excel 
 ✓ ✓ ✓  ✓ 

VBA 

macros 
 ✓ ✓ ✓  ✓ 

Office 

Scripts 
 ✓  ✓  

Microsoft 

Access 
     ✓ 

  

 

P
O

W
E
R

  

P
L
A

T
F
O

R
M

 

 

Power BI 

and DAX 
 ✓ ✓ ✓  ✓ 

Power 

Apps 
 ✓  ✓  

Power 

Automate 
 ✓ ✓ ✓  ✓ 

  

S
Q

L
 

S
E
R

V
E
R

 

Reporting 

Services 
 ✓ ✓ ✓  ✓ 

Report 

Builder 
 ✓  ✓  ✓ 

Integration 

Services 
 ✓ ✓ ✓  ✓ 

Analysis 

Services 
 ✓  ✓  

  

 C
O

D
I
N

G
 

L
A

N
G

U
A

G
E
S

 

SQL  ✓ ✓ ✓  ✓ 

Visual C#  ✓ ✓ ✓  ✓ 

Python  ✓ ✓ ✓  ✓ 

mailto:sales@wiseowl.co.uk


 
 

www.wiseowl.co.uk   |   (0161) 883 3606   |   sales@wiseowl.co.uk 

 

 

mailto:sales@wiseowl.co.uk

