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CHAPTER 1 - POWER BI BASICS

1.1 What is Power BI Desktop?

Power BI Desktop is a standalone software application from Microsoft which allows you to load data 
into a model, and then create pretty reports like this:

You can then publish these reports to the 
Power BI Service, allowing anyone who has 
a paid Power BI account to view them:

The same report as seen in Power BI Service 
through a browser.

This report contains an image, a text box and 6 visuals 
(a slicer, 3 cards a bar chart and a map).

The report is based on tables which we’ve imported into 
a model:
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1.2 Installing and Updating Power BI

There are two ways to install Power BI, depending on whether you want to get automatic monthly 
updates.

From Microsoft Store

The easiest way to install Power BI is 
from the Microsoft Store:

Installing without Automatic Updates

If you want to control when monthly Power BI 
desktop updates are installed on your computer, 
choose this installation option instead:

Every month Power BI will update automatically as Microsoft release new features.  
The best way to keep track of what these new features entail is to subscribe to the 
Wise Owl newsletter.  This goes out at the start of each month and (among other 
things) summarises and explains any new updates to Power BI.

Wise 
Owl’s 
Hint

a) Type in Power BI Desktop in the Microsoft 
Store search bar.

b) Choose to install the Power BI Desktop 
application (although in this case it’s 
already installed on this user’s machine).

a) Googling install power bi desktop should lead you to 
this page in your browser.

b) Click to download the latest version of Power BI 
Desktop (it’ll be up to you to update this manually to 
incorporate changes).
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CHAPTER 2 - GETTING STARTED

2.1 Getting Started in Power BI Desktop

This chapter describes the basic workflow you’ll use to build a report in Power BI Desktop:

Stage Details
Loading and 
transforming data

Loading one or more tables from various data sources, cleansing the data and 
linking the tables together if necessary.

Creating a report Using the data that you’ve loaded to create a report, including visuals like charts.

Publishing this Publishing the results to your report server (usually Microsoft’s Power BI Service) 
so that other people can view your reports.

You’ll find much more detail on the ideas mentioned in this chapter in later parts of this courseware.

Example for this Chapter

To demonstrate the basic process of building a report, we’ll import a table of data from a webpage 
and create and publish a report based upon this:

We’ll then present this data using visuals such as this chart:

Finally we will publish this report to the Power BI Service, 
so that anyone in your organisation can see it:

At the time of writing these are the snow 
conditions at selected resorts courtesy of 
https://www.igluski.com/snow-reports . 
We’ll transform the data to tidy it up (for 
example, we can remove columns we 
don’t need).

We can use the imported, cleaned data to create a variety of 
visuals, such as this chart.

The final report published to Power BI Service, and viewed 
through your browser.

https://www.igluski.com/snow-reports
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2.2 Working with Files

Creating New Files

You can create a new report in Power BI Desktop in the following ways:

Opening and Saving Files

You can open and save files using options in the File menu:

a) From the Power BI Desktop menu choose the File menu.

d) Files that you save in 
Power BI Desktop will have 
a pbix extension.

a) If you already have Power BI 
Desktop open, select the File menu.

b) Click on this icon to create a new 
report.

b) Choose one of these menu items to open or save a report (the 
dialog box which appears is similar whichever you choose).

c) Click on this button to find the 
folder which contains (or will 
contain) your report.

e) Click on this button to open 
the report you’ve chosen or 
to save this report

Every time you open a Power BI Desktop report a new instance of the application 
will launch, leaving the current report you’re working on unaffected.  To close a report 
you must close down the Power BI Desktop application containing it (there is no 
option to close a report but still leave Power BI Desktop running).

Wise 
Owl’s 
Hint
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2.3 Views in Power BI Desktop

The most important components of the Power BI Desktop screen are as follows:

Switching Panes

You can use the icons on the right-hand side of your Power BI screen to choose what to show:

You can click the arrows to 
hide each of these panes.

This is the Power 
BI Desktop menu 
and ribbon. 

You can use the Pane Switcher to change 
what to look at.  The two main views are 
Data and Format, as explained below.

These tools allow you to switch between 
designing reports for viewing on desktop 
computers or mobile phones.

These tools allow you to switch between 
the 3 main views in Power BI Desktop: 
Report view, Table view and Model view.

You can use the slider to zoom in and out, although you 
may find it easier to hold down the  Ctrl  key and use your 
mouse wheel instead.

Click on this icon to see the data tables in your model …

… or this icon to see the format properties of the thing 
you currently have selected (in this case a chart visual).

You can also use these tools on the View tab of the 
Power BI Desktop ribbon to choose what you want to 
view.
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Report, Table and Model View

You can switch between the three views of a report using the tools on the left of the screen:

View Icon What it shows Example view

Report

The report that 
you’re creating, 
consisting of visuals 
and shapes.

Table

The tables of data 
that you’ve loaded 
into your model (you 
can see one table at 
a time in this view).

Model

The links between 
the tables in your 
model, called 
relationships in 
Power BI Desktop.

The 4th icon – if present – allows you to create queries in DAX to interrogate the data 
upon which your report is based, but this is definitely not something to consider in 
this courseware chapter!

Wise 
Owl’s 
Hint
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2.4 Getting Data

The first stage in building a report is to find some data!

 

You can optionally rename a table after importing it into your report:

a) From the ribbon, choose Home | Get Data then choose a type of 
data source.  Here we’re choosing a Web source.

d) Click on this button to load the 
data into your model.

a) Click on this icon to show the Data pane.

b) Choose Rename from the menu which 
appears.

b) Each type of data source requires different information to allow 
your report to connect to it.  For a web source you need to enter 
the URL of the page and then click OK.  You may also be asked to 
enter credentials if the website requires some.

c) Tick which table you want to 
import from this page (the best 
way to see what each looks like 
is to click on it).

c) Enter a new name for your table and 
press  Enter  .
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2.5 Transforming Data

You’ll often need to make changes to the data you have imported so that it can be presented easily 
in visuals.  This process is known as transforming data.

Editing Queries /  Transforming Data

Each table that you import into a report generates a query which tells Power BI Desktop which data 
to get (and how to get it).  You can edit these queries in (at least) 3 different ways:

You can right-click on a table in the Fields pane and choose Edit 
query…

…or you can choose this option from the Home tab of the ribbon 
(although it says it’s doing something different, transforming data and 
editing a query are actually the same thing!).

As with everything else in this chapter, we will go into this topic in much more detail 
later in this courseware.

Wise 
Owl’s 
Hint

Alternatively, you could click on this button at the point at which you’re 
first loading data to go directly into the Power BI Query Editor.

We will change the column 
headings, turn some 

column into numbers and 
remove the final column.
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The Power BI Query Editor

Choosing to edit a query as described above opens the Power Query Editor tool within Power BI 
Desktop.

Promoting Row Headers

For our example the first thing you need to do is to make the first row your table headers:

Although you’re still working in the 
same Power BI Desktop file, the 
Power Query Editor has a different 
ribbon with options related to 
modifying data.

When you have finished cleaning your 
data click Close & Apply to close the 
Power Query Editor.

This program to edit Power BI queries has gone by many names in the past!  This 
courseware will call it Query Editor, although this name seems to have been 
abandoned by Microsoft.  Little known fact: everything that you can do using Query 
Editor in Power BI Desktop you can also do when getting data in Excel.

Wise 
Owl’s 
Hint

a) To tell Power BI Desktop to use the first 
row of the table as column headers, click 
on this tool on the Home tab of the 
Query Editor ribbon:

b) Query Editor will add two steps: one to promote your row headers (as 
requested), and then another to change the data types of the columns 
following this step.  Query Editor will often insert silent additional steps like 
this to second-guess your intentions, and (to be fair) nearly always gets 
these right.
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Replacing Values

To allow us to average snowfalls for our data we need to remove the cm suffices then convert the 
resulting data to integer numbers:

Changing Data Types

You can now change the data 
types of the 3 columns you have 
selected:

Removing Columns

Finally, we’re not interested in the last snowfall depth, so we’ll remove this column.

a) Select the first column whose cm suffices you 
want to remove, then hold down the  Shift  key 
and select the last one (this is the easiest way to 
select multiple columns in Query Editor).

b) Right-click on the selected columns and choose 
to replace values.

c) Choose to replace the text cm with nothing, then select  OK  .

Right-click on the 3 columns and 
choose to change their data types 
to Whole Number (note that this 
would have generated errors if we 
had done this earlier).

Right-click on the Last Snowfall column and remove it 
from your query.



Chapter 2 - Getting Started

© Copyright 2025  Page 19

2.6 Creating Visuals

Visuals are the tables, charts or other gizmos which display the data in your report.  There are many 
types of visual ( you’ll learn a lot more about them in later chapters of this courseware).

Inserting a Visual

Probably the easiest way to add a visual to a report is as follows:

Assigning Grouping Fields to a Visual

Once you have inserted a visual you can begin assigning fields to it:

  

b) Click on the side bar to the right of the visuals pane (this appears on both 
the Home tab and the Insert tab of the ribbon).

b) Choose which visual you want to create.  If you get this wrong, 
you can always change it after creating your visual by clicking 
here:

a) Make sure that you’re in Report view, otherwise you won’t be able to add 
visuals!

The easiest way to 
assign fields to a visual 
is to click on this tool.

You can then click on 
each part of a chart 
(here we’re saying what 
will appear on the 
horizontal axis of this 
column chart) then tick 
the field you want to 
include.
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Assigning Numerical Fields

You can assign numerical fields in the same way, then change how you want to aggregate them:

c) Once you’ve assigned a numerical field to a 
chart you can click on it to say how you want to 
aggregate it (here we’ve changed from 
summing the upper slopes’ snow depth for each 
country – which would be fairly meaningless – 
to averaging it). 

a) Click on the Y axis box the field well and choose to 
show the Upper Slopes snow depth to get this:

b) Click on the field you’ve added and change it:
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2.7 Three Ways to Format Visuals

Much of your time in Power BI Desktop will probably be spent applying formatting like this:

In Situ Selection

There are a few parts of a chart that you can edit on the chart itself:

Changing what’s on your Chart

You can choose to add or remove some parts of your 
chart using the following icon:

The chart as it initially appears – the 
title is hard to read and doesn’t stand 
out, and it could do with a bit of oomph.

A chart which has been formatted within 
an inch of its life (including the addition 
of data labels showing the average 
upper bound snow level by country).

The parts of the chart you can edit directly are shown in red boxes.

When you double-click on any of these with the chart selected you will 
be able to change the text displayed.

Click on this icon to add or remove certain chart 
components (here we can add or remove the title, data 
labels or a slider).

The More options button is less useful than you might think: it just takes you to the 
Format pane on the right-hand side of Power BI Desktop.

Wise 
Owl’s 
Hint
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The Format Pane

You’ll spend much of your time in Power BI Desktop using the Format pane:
 

a) Select the visual you want to 
format (otherwise you’ll see the 
formatting properties of the page to 
which it belongs instead).

b) Optionally, reduce the number of 
properties displayed by typing in 
part of the name of the one you 
want to change (here we’ve typed 
Title in the search box).

c) Expand a card to show its range of 
formatting options, and make 
changes.

d) Some of the changes made to 
change the title to this:

As a short-cut, double-click on a visual  to select any part of it that you want to format; 
the relevant card will automatically then be selected in the Format pane.

Wise 
Owl’s 
Hint
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2.8 Publishing your Report

When you’ve finished your report you will probably want to share it!

a) Check that you’re signed 
in to a Power BI account.

b) Click on this Publish 
button on the Home tab of 
the Power BI ribbon.

c) If you have unsaved changes you will be asked at this point to 
save them (you can’t publish a report which contains unsaved 
changes).

d) Choose to publish 
to the default My 
workspace (see 
hint below for 
more on this).

e) Click on this link to see your report in Power BI 
Service on the Internet (you may be asked to log in 
to your account again at this point).

f) Your report as it will appear to the world 
(provided of course that they have the right 
security level and licence …).

A (much) later chapter in this courseware will cover publishing in more detail, 
including an explanation of workspaces (and why you might want to create them), 
how to create dashboards and much more besides.

Wise 
Owl’s 
Hint
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What we do! 
 
 
 

 

 

     
Basic 

training 
Advanced 
training 

Systems / 
consultancy 

         

 
      

 

O
ff

ic
e
 

 Microsoft Excel  
   

  VBA macros  
   

  Office Scripts  
 

  

  Microsoft Access     
 

 
 

 
    

        

 

 
      

 

P
o
w

er
 B

I,
 e

tc
  Power BI and DAX  

   

  Power Apps  
 

  

  Power Automate (both)  
  

 

 

 
 

 
    

        

 

 
 

 
    

 

S
Q

L
 S

e
r
v
e
r
 

 SQL  
   

  Reporting Services  
   

  Report Builder  
   

  Integration Services  
   

  Analysis Services  
 

  

 

 
 

 
    

        

 

 
 

 
    

 

C
o

d
in

g
 

 Visual C#   
   

  VB programming    
 

  MySQL  
   

  Python  
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