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CHAPTER 1 - POWER BI BASICS

1.1 What is Power BI Desktop?

Power BI Desktop is a standalone software application from Microsoft which allows you to load data 
into a model, and then create pretty reports like this:

You can then publish these reports to the Power BI Service, 
allowing anyone who has a paid Power BI account to view them:

This report contains five visualisations (a pie chart, a 
tree map, a gauge, a map and a KPI).

The report is based on tables which we’ve imported into 
a model:

Another report as seen in Power 
BI Service through a browser.
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1.2 Installing and Updating Power BI

The easiest way to install Power BI is from the Microsoft Store:

You’ll then be able to run Power BI Desktop like any other Windows program:

a) Type in Microsoft Store into the Cortana search bar.

b) Run the Windows program to go to the MS Store.

c) Type in power bi in the search 
box at the top of Microsoft Store, 
and choose Power BI Desktop.

d) Click on this button to install Power BI Desktop.  
You’ll see something like this:

The icon you’ll 
grow to know 
and love!

Click on this 
cross to close 
the start screen.

Every month Power BI will update automatically as Microsoft release new features.  
The best way to keep track of what these new features entail is to subscribe to the 
Wise Owl newsletter.  This goes out at the start of each month and (among other 
things) summarises and explains any new updates to Power BI.

Wise 
Owl’s 
Hint
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CHAPTER 2 - GETTING STARTED

2.1 Getting Started in Power BI Desktop

This chapter describes the basic workflow you’ll use to build a report in Power BI Desktop.  You’ll 
find much more detail on the ideas mentioned in this chapter in later parts of this courseware.

Example for this Chapter

To demonstrate the basic process of building a report, we’ll import a table of data from a webpage:

We’ll then present this data using 
visualisations such as this chart:

Showing Keyboard Shortcuts

If you want to know what keyboard short-cuts 
are available to you in Power BI Desktop, 
press  Shift  +  ?  to see this dialog box appear!

We can use the imported, cleaned data to 
create a variety of visualisations.

You can use this pop-up window to see what short-cut 
keys are available.  Wise Owl are normally advocates of 
learning and using short-cut keys, but Power BI is a very 
mouse-intensive application.

At the time of writing, this is the start 
of the list of the top 100 films from 
the Rotten Tomatoes website at 
http://bit.ly/29IiGk9. We’ll transform 
the data to tidy it up (for example, we 
can remove columns we don’t need).

http://bit.ly/29IiGk9
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2.2 Working with Files

Creating New Files

When you open Power BI Desktop you are automatically provided with a blank report to work with.  
You can choose to create a new file or open an existing one from the File menu:

Saving and Closing Files

You can save files using options in the File menu:

Choose File | New to 
create a new blank report.

You can open a 
recently-used 
file by clicking 
its name in the 
list.Choose File | Open report 

to pick an existing file to 
open.

Every time you create or open a Power BI file from within Power BI Desktop, the 
application will launch a new instance of the Power BI Desktop application and 
switch to it, leaving the current one you’re working with unaffected.

Wise 
Owl’s 
Hint

You can save a file 
with its current name 
and location by 
clicking the floppy 
disk tool ...

Files that you save in Power BI Desktop will have a pbix 
extension and a file type of Microsoft Power BI Desktop 
Document.

... or by choosing 
File | Save.

You can save a file with a new name and location by choosing 
File | Save As and then using the dialog box which appears.

There is currently no option to close a file that you’re working on, while still leaving 
the Power BI Desktop application running.

Wise 
Owl’s 
Hint
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2.3 The Power BI Desktop Screen

The most important components of the Power BI Desktop screen are as follows:

You can switch between the three views of a report using the tools on the left of the screen:

View Icon What it shows Example view

Report The report that you’re creating, consisting 
of visualisations and shapes.

Data
The tables of data that you’ve loaded into 
your model (you can see one table at a 
time in this view).

Model
The links between the tables in your 
model, called relationships in Power BI 
Desktop.

You can click the arrows to 
hide each of these panes.

The ribbon tabs (the two on the 
right won’t always be visible).

The main area of the screen changes 
depending on which view you are in.  

The panes on the right will change depending 
on which view you have selected.

These tools allow you to change the view of your report and are 
explained in the table below.
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2.4 Getting Data

The first stage in building a report is to find some data!

 

You can optionally rename a table after importing it into the report:

a) From the ribbon, choose Home | Get Data then choose a type of 
data source.  Here we’re choosing a Web source.

b) Each type of data source requires different information to allow 
your report to connect to it.  For a web source you need to enter 
the URL of the page and then click OK.  You may also be asked to 
enter credentials if the website requires some.

c) Tick which table you 
want to import from 
this page (the best 
way to see what 
each looks like is to 
click on it).

d) Click on this button 
to load the data into 
your model.

a) In the Fields pane 
click the  ...  tool 
next to the table 
name.

b) Choose Rename 
from the menu 
which appears.

c) Enter a new name 
and press  ↩  .
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2.5 Transforming Data

You’ll often need to make changes to the data you have imported so that it can be presented easily 
in the Report view.  This process is known as transforming data.

Editing a Query

Each table that you import into a report generates a query which tells Power BI Desktop which data 
to get.  You can edit any query you have created as shown in the diagram below:

The Power Query Editor

Choosing to edit a query as described above opens the Power Query Editor tool within Power BI 
Desktop.

You can right-click on a table in the Fields pane and choose Edit query…

…or you can choose this option from the Home tab of the ribbon (although it says it’s 
doing something different, transforming data and editing a query are the same thing).

We don’t need the Tomatometer column, 
so we’ll delete it … 

… and we’ll give all the other columns 
more sensible names.

Although you’re still working in the same 
Power BI Desktop file, the Power Query 
Editor has a different ribbon with options 
related to modifying data.

When you have finished cleaning your data 
click Close & Apply to close the Power 
Query Editor.
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Removing and Renaming Columns

You can remove and rename columns in Power Query by 
right-clicking:

Splitting Columns

We’ll cover this in more detail in the Query Editor chapter of this courseware, but here’s a quick guide 
to how you can split the film column into the title and year of release:

Right-click on a column you want to rename and choose this option.  You 
can then type in a new name for the column (as below) and press  ↩  .

Right-click on the 
column that you 
want to delete and 
choose to remove 
it.

Click on the column you want to split and choose this 
option.  Remarkably, Power BI intuits what you want to 
do, although you’ll need to choose Right-most 
delimiter to make sure you pick out the last open 
bracket:

By repeating splitting, removing and renaming columns 
you should be able to get the information required!

There’s no official Undo tool in Query Editor, but you can delete the last steps that 
you created in the right-hand side of the window.

Wise 
Owl’s 
Hint
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2.6 Creating Visualisations

Visualisations, or visuals for short, are the things which display the data in your report.  There are 
many types of visual ( you’ll learn a lot more about them in later chapters of this courseware).

Inserting a Visualisation

A simple way to insert a visualisation is to click on the one you want in the Visualizations pane on 
the right of the screen.  Make sure that you’re in the Report view or you won’t see this pane!

Assigning Fields to a Visualisation

Once you have inserted a visual you can begin assigning fields to it.

 

Go to the Report view and look 
for the Visualizations pane on 
the right of the screen.

You can click any icon to insert a 
visual into the report.  Here we 
are adding a clustered column 
chart.

… or drag it onto the right card.  Here we’re 
choosing to show the total number of reviews 
for each film.

You can either tick a field to ask Power BI 
to add it to the most sensible card in the 
field well …



Chapter 2 - Getting Started

© Copyright 2023  Page 19

2.7 Formatting Visuals

Each visual has a large range of formatting options and, again, 
this is covered in much more detail later.  Here’s a taster to set 
the title of the chart.

Searching for Format Properties

Often the easiest way to find a property is to search for it:

a) Click on the formatting tool above the palette of visuals to show the 
formatting options for the visual that you have selected.

c) Click the  ^  symbol next to a category to see the formatting options in 
that category (here we’ve expanded the Title card).

b) Decide whether this is something which is common to all visuals (as 
here, so we choose General), or specific only to some visuals.  After a 
short while you’ll become familiar with which properties are general to 
all visuals and which are specific.

d) Here we’ve changed the title text, font colour, background colour, 
alignment and text size to get this:

a) Type a search phrase into the box at the top of the formatting 
pane.

b) Power BI will filter the formatting properties to show only 
those whose names contain the text you’ve typed in (this list 
combines properties from the Visual and General tabs).
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2.8 Filtering Visuals

Our chart currently displays a column for each of the one hundred rows in the Top films table.  We 
can filter the data for our visual to show only the top five rated films.

Adding Fields to the Filters List

The Filters pane appears to the left of the field well and shows any fields you have added to the 
visual.  We need to add the Rank field to the Filters list manually, as shown in the diagram below:

Applying a Filter

You can apply a filter to the visual using any field in the Filters list:

a) Click and drag the Rank 
field from the Fields list on 
the right of the screen.

b) Drop the Rank field into 
the Filters on this visual 
box in the Filters pane.

a) For the Rank field that you added to the visual level filters box in the 
previous stage, choose Advanced filtering from this drop down list.

b) Choose is less than or equal to and then enter a value of 5 in the box 
below.

c) Click Apply filter to apply your changes and filter the selected visual.
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2.9 Working with Report Pages

Changing the Page View

You can use the following menu on the View tab of the ribbon to change how a report page appears:

Page Settings

The diagram below shows how you can change the page background 
and size:

The settings are as follows:

Setting What it means

Fit to Page Contents are scaled to best fit the page 
(this is the default, and preserves the 
best aspect ratio).

Fit to Width Contents are scaled to fit within the width 
of the page.

Actual Size Contents are displayed at full size.

a) Make sure that you don’t have any visualisations selected, then click on 
the formatting tool to see your page properties.

b) Choose from one of the standard page sizes, or choose Custom from 
the list to create your own.

c) Set a background colour and/or (as here) an image, including any 
transparency settings.  This choice would look as follows:

Power BI Desktop will always open a report using the current view setting you had 
in place at the time you last saved it.

Wise 
Owl’s 
Hint
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Renaming Pages

You can right-click on any page to rename it:

Adding and Deleting Pages

You can add and remove pages as follows:

 

Hiding Pages

A hidden page will still appear in Power BI Desktop, but won’t be visible in your published report:

You can drag pages to right or left to 
change their position in the report.

Wise 
Owl’s 
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Right-click on any page to change its name …

… making a report much easier to understand and 
to use.

Right-click on any page and choose this option 
to delete it.  You can also click on the cross at 
the top right of the page name:

Click on this button to add a new page at the end of your 
current ones.

Right-click on a page and choose this option to hide it.  This 
allows you to work on the page, without it being visible to 
viewers of your published report.  A hidden page is indicated 
with a difficult-to-see, eye icon (eye-con?) to the left of its 
name.
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2.10 Themes

You can apply a theme to a report to change the colour scheme it uses:

Once you’ve applied a theme, all the colour palettes you see will be influenced by it:

... to apply the colours of the theme to all the visuals on all 
pages of your report.

Choose a theme on the View tab of the Power 
BI ribbon …

A typical colour palette using 
the Default theme ...

... and what it looks like if you 
choose the Temperature 
theme as above.

If your organisation has a custom theme you can click on the following option to 
search for and apply it (and if it doesn’t, why not create your own theme?).

Wise 
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